Diagnosing and Fixing Errors After Installation

Are you seeing errors in the Tag Assistant after installing and configuring our app? Here are most common reasons why.

Below outlines the most common issues encountered after installing our app, importing our GTM container, and testing out your GTM container in preview mode. 

Invalid or Missing Account ID

Are you getting this error in tag assistant:

Screen Shot 2019-07-21 at 4.30.24 PM

If you're getting this error then follow these steps:

  1. View your page source code 
  2. Search for "GTM" (for mac users: Command + F)  to see if any matches
  3. If there are matches then check that there isn't any trailing spaces in front of your GTM ID:

leading-space

If there are then go back to our app settings in the Shopify Admin > remove the whitespace > click save & update. 

<script> tag must not be included in a <div>

If you are getting this error on the thank you page:

Screen Shot 2019-07-21 at 4.40.28 PM

Then you can safely ignore this. This is a recommendation from Google but unfortunately we can't control <div> placements on the thank you page as this is all standard Shopify behavior. We have not seen this affect any conversion tracking to date. 

AdWords tags are empty or null

If you are testing your tags while GTM is in preview mode and all of your tags are undefined/null and you see the dataLayer empty in preview mode then double check that { elevar-body-end.liqud } has been inserted into the theme.liquid template:

theme-body

If it is missing then try saving and updating the app again. 

If this still doesn't work then you are probably missing the closing </body> tag in your theme. You can confirm by searching your theme for body and see if you can find the closing tag version. 

If you are still stuck then email us at help@getelevar.com so we can help you out!